apt でバージョンを指定してインストールする

Ubuntu でバージョンを指定してパッケージをインストールする方法。

バージョン一覧

$ apt-cache madison elixir
    elixir |   1.10.3-1 | http://binaries.erlang-solutions.com/debian focal/contrib amd64 Packages
    elixir |   1.10.2-1 | http://binaries.erlang-solutions.com/debian focal/contrib amd64 Packages
    elixir | 1.9.1.dfsg-1.3 | http://ca.archive.ubuntu.com/ubuntu focal/universe amd64 Packages

現在のバージョン

$ apt-cache policy elixir
elixir:
  Installed: 1.10.3-1
  Candidate: 1.10.3-1
  Version table:
 *** 1.10.3-1 999
        999 http://binaries.erlang-solutions.com/debian focal/contrib amd64 Packages
        100 /var/lib/dpkg/status
     1.10.2-1 999
        999 http://binaries.erlang-solutions.com/debian focal/contrib amd64 Packages
     1.9.1.dfsg-1.3 500
        500 http://ca.archive.ubuntu.com/ubuntu focal/universe amd64 Packages

バージョンを指定して apt install

apt install elixir=1.10.3-1

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です